Homesource Forums

Homeworld Source Editing Talk
It is currently Sat Jun 24, 2017 1:55 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Thu May 17, 2007 5:05 pm 
Offline

Joined: Mon May 14, 2007 2:25 pm
Posts: 8
here are some issues i had so far (where to post these?):

general :
---------
- right click : special action not working (dock,repair) (forget this, it's doubleclick not rightclick :roll: )
- pressing "l" will cancel batch instead ofjumping to launch manager
- mines can't be shot down?! correct?
- saved missions don't get deleted

mission scripting :
-------------------
mission 9 : alien ship.
upon "capturing" my support frigate (after it's controlled ships destroyed without getting captured) animation saying
"lost control of capital ship" but nothing more, can't even attack captured ship! knowing what to do, salvaging from alien
ship and then wanting to jump away i oddly get my support frigat back but jump won't initiate for a minute or so...
mission 10 : shipyard
even after all enemy ships are destroyed the objective is not completed....

when run in window :
- game stops if mouse focus is lost!
- in sensors(and in space) when issuing a move order, moving the camera with right click it just spins at highspeed
- focussing with alt-click doesn't work

[edit:18.05 00:22]


Top
 Profile  
 
PostPosted: Fri May 18, 2007 2:22 am 
Offline
Site Admin
User avatar

Joined: Tue Dec 14, 2004 12:41 am
Posts: 326
bernstein wrote:
here are some issues i had so far (where to post these?)


Posting in this thread about problems you've discovered through using the binaries is just fine :)

I'll check these out but offhand:

Mines can be targeted and destroyed, but you must hold down the "force attack" key combination of ctrl+shift... the same way you'd force an attack on one of your own ships.

I think the game pausing if the mouse focus is lost is supposed to be a feature... albeit an irritating one if you just want to let the game run while harvesting out a level.

Focus-with-alt-click does work... mostly... sometimes... but it's tempermental under linux... ;)

The other items you mentioned sound like issues that do need to be addressed...

Thanks for your help! :)


Top
 Profile  
 
PostPosted: Fri May 18, 2007 7:58 am 
Offline
Site Admin
User avatar

Joined: Tue Dec 14, 2004 12:41 am
Posts: 326
zapkitty wrote:
Mines can be targeted and destroyed, but you must hold down the "force attack" key combination of alt+shift... the same way you'd force an attack on one of your own ships


Of course I actually meant to say "ctrl-shift"... so I edited it to say "ctrl-shift"... just so you know... ;)


Top
 Profile  
 
PostPosted: Fri May 18, 2007 8:52 am 
Offline

Joined: Mon May 14, 2007 2:25 pm
Posts: 8
zapkitty wrote:
zapkitty wrote:
Mines can be targeted and destroyed, but you must hold down the "force attack" key combination of alt+shift... the same way you'd force an attack on one of your own ships


ok this works... sorry forgot this combo too :oops:

Quote:
The other items you mentioned sound like issues that do need to be addressed...


well i prefer the term "low priority bugs" :-)


Top
 Profile  
 
PostPosted: Wed May 30, 2007 7:38 am 
Offline

Joined: Mon May 14, 2007 2:25 pm
Posts: 8
bernstein wrote:
zapkitty wrote:
The other items you mentioned sound like issues that do need to be addressed...

well i prefer the term "low priority bugs" :-)


oh my! forget what i wrote.... i read "... do NOT need to ..." instead of "... do need to ..." :oops:


Top
 Profile  
 
PostPosted: Tue Aug 14, 2007 12:23 pm 
Offline

Joined: Mon May 14, 2007 2:25 pm
Posts: 8
bernstein wrote:
mission 10 : shipyard
even after all enemy ships are destroyed the objective is not completed....

restarting the mission did the trick.
not sure why it didn't work the first time though... maybe it was because i captured the heavy cruiser or the game thought that there were still enemy ships or i just was unable to find them...


Top
 Profile  
 
PostPosted: Wed Aug 15, 2007 10:43 pm 
Offline
Site Admin
User avatar

Joined: Tue Dec 14, 2004 12:41 am
Posts: 326
bernstein wrote:
bernstein wrote:
mission 10 :
restarting the mission did the trick.
not sure why it didn't work the first time though... maybe it was because i captured the heavy cruiser or the game thought that there were still enemy ships or i just was unable to find them...


No. It's a bug... You can salvage and take away all the ships you can catch in this mission including the cruiser and the carrier.

It's a bug... specifically a mission design that's too linear for its own good. The game is convinced that you are going to send a minimum amount of attack ships to the station via the main "dust highway" running from the Mothership to the station... and it assumes you will attack "down" from the point on that main highway adjacent to the station.

The game further assumes that the Defender wall around the station (or at least one ship thereof) will still be there when the attack with the "certain amount of ships" begins.

So major attack force sweeping down from the highway at the right spot and at least one Defender in place to watch it happen... or some bad code stops counting ship kills.

But if you make sure those conditions are technically met then you can swipe all the ships you want.

This actually needs to be fixed in the mission script, of course...


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group