Homesource Forums

Homeworld Source Editing Talk
It is currently Mon Apr 24, 2017 4:04 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Freaky Linux problem
PostPosted: Fri Dec 29, 2006 7:40 am 
Offline
coder

Joined: Tue Nov 07, 2006 4:40 am
Posts: 236
Hi.

Hope everyone had a good holiday. :)

I've got an odd problem, and wanted to describe it here in case anyone else experiences it, or can make a suggestion I've missed.

I updated both my tower and my laptop to OpenSuse 10.2 from 10.1.
The upgrade went without a hitch apart from the obvious changes in the GL drivers.

Tower uses a NVIDIA card, and the laptop is ATI. I downloaded the drivers, installed then onto the kernel, Xorg, etc which also seemed to be fine.

The problem is that on the tower, when I run homewroldSDL, it's erratic. for a few seconds it runs beautifully, and then for a few seconds it runs badly and jerks, then fine again.
No problem on the laptop, it runs beautifully all the time.

Replaced stuff, deleted stuff and given up for a while.

Things left to try:
1)install another GL && SDL based game and see if it does the same (scp)
2)Remove drivers and try using Mesa. (Bleugh :( )

Any other suggestions? :)

Aunxx


Top
 Profile  
 
 Post subject:
PostPosted: Fri Dec 29, 2006 7:53 pm 
Offline
coder
User avatar

Joined: Wed Oct 04, 2006 8:13 pm
Posts: 94
Location: UTC -0500
so, once you try this, what happens when you run quake 2 sdl or ioquake3 .. or some other opengl sdl game?

_________________
http://againsttcpa.com/what-is-tcpa.html
http://google.com/search?q=c+programming+faq
http://research.att.com/~bs
acronyms.ch, neworder.box.sk


Top
 Profile  
 
 Post subject:
PostPosted: Wed Jan 24, 2007 2:14 pm 
Offline
coder

Joined: Wed Nov 15, 2006 8:15 am
Posts: 100
I think I have experience the same problem with my tower, but it was when I switch from a 2.6.17 to 2.6.18 kernel...
What is your kernel version? Maybe the new drivers and kernel don't like to work together.
I will try homeworld on my new laptop to see if it's related to the kernel only or not.


Top
 Profile  
 
 Post subject: Kerneling
PostPosted: Thu Nov 01, 2007 9:43 am 
Offline

Joined: Wed Oct 31, 2007 9:12 am
Posts: 1
To prevent skipping of games, music, movies, or anything else to do with multimedia you need to recompile the kernel with the internel clock set to at least 300 Hz. For a full fledged multimedia, pure desktop setup go with 1000Hz. The default setting for most distros kernels is 250Hz which is a good middle of the way setting for most people but not so good if gaming :) on Linux. Compile the kernel using the latest 2.6.23.1 kernel since it comes the Completely Fair Scheduler by default. Make sure to check if your particular distro requires an initrd.img to boot with the new kernel. I know Debian and Ubuntu, and company do, but I don't know about others. I'm not much of a coder, I just like the configuring part, which is challenge enough for me :) Hope this helps and sorry if it seems I was reviving a dead thread. Let me know what yall think.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group